aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.0/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/500-oxnas-sata.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
new file mode 100644
index 0000000000..c9b11e99d8
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
@@ -0,0 +1,30 @@
+Index: linux-4.0-rc4/drivers/ata/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/ata/Kconfig
++++ linux-4.0-rc4/drivers/ata/Kconfig
+@@ -401,6 +401,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+Index: linux-4.0-rc4/drivers/ata/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/ata/Makefile
++++ linux-4.0-rc4/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o