aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/350-oxnas-reset.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-3.14/350-oxnas-reset.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/350-oxnas-reset.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/350-oxnas-reset.patch b/target/linux/oxnas/patches-3.14/350-oxnas-reset.patch
new file mode 100644
index 0000000000..820d70b2df
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/350-oxnas-reset.patch
@@ -0,0 +1,20 @@
+Index: linux-3.14.18/drivers/reset/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/reset/Kconfig
++++ linux-3.14.18/drivers/reset/Kconfig
+@@ -11,3 +11,7 @@ menuconfig RESET_CONTROLLER
+ via GPIOs or SoC-internal reset controller modules.
+
+ If unsure, say no.
++
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
+Index: linux-3.14.18/drivers/reset/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/reset/Makefile
++++ linux-3.14.18/drivers/reset/Makefile
+@@ -1,2 +1,3 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o