aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch b/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..ca0ccb83c8
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/340-oxnas-pcie.patch
@@ -0,0 +1,23 @@
+Index: linux-3.14.18/drivers/pci/host/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/pci/host/Kconfig
++++ linux-3.14.18/drivers/pci/host/Kconfig
+@@ -33,4 +33,9 @@ config PCI_RCAR_GEN2
+ There are 3 internal PCI controllers available with a single
+ built-in EHCI/OHCI host controller present on each one.
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+Index: linux-3.14.18/drivers/pci/host/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/pci/host/Makefile
++++ linux-3.14.18/drivers/pci/host/Makefile
+@@ -4,3 +4,4 @@ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o