aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
new file mode 100644
index 0000000000..1eb74debcf
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
@@ -0,0 +1,24 @@
+Index: linux-3.14.18/drivers/clocksource/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/clocksource/Kconfig
++++ linux-3.14.18/drivers/clocksource/Kconfig
+@@ -140,3 +140,9 @@ config VF_PIT_TIMER
+ bool
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
++
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
+Index: linux-3.14.18/drivers/clocksource/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/clocksource/Makefile
++++ linux-3.14.18/drivers/clocksource/Makefile
+@@ -37,3 +37,5 @@ obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arc
+ obj-$(CONFIG_ARM_GLOBAL_TIMER) += arm_global_timer.o
+ obj-$(CONFIG_CLKSRC_METAG_GENERIC) += metag_generic.o
+ obj-$(CONFIG_ARCH_HAS_TICK_BROADCAST) += dummy_timer.o
++
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o