aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/Makefile')
-rw-r--r--target/linux/oxnas/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/target/linux/oxnas/Makefile b/target/linux/oxnas/Makefile
index 0d9d356734..52d57f336a 100644
--- a/target/linux/oxnas/Makefile
+++ b/target/linux/oxnas/Makefile
@@ -1,29 +1,21 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=oxnas
-BOARDNAME:=PLXTECH/Oxford NAS782x/OX82x
+BOARDNAME:=PLXTECH/Oxford NAS782x/OX8xx
+SUBTARGETS:=ox810se ox820
+FEATURES:=gpio ramdisk rtc squashfs
DEVICE_TYPE:=nas
-FEATURES:=gpio nand pcie usb ramdisk rtc squashfs ubifs
-CPU_TYPE:=mpcore
MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
- kmod-ata-core kmod-ata-oxnas-sata kmod-button-hotplug \
- kmod-input-gpio-keys-polled kmod-usb-ledtrig-usbport \
- kmod-ledtrig-timer kmod-leds-gpio kmod-usb2-oxnas \
- kmod-usb-storage uboot-envtools uboot-oxnas-ox820
+ kmod-button-hotplug kmod-input-gpio-keys-polled \
+ kmod-ledtrig-timer kmod-leds-gpio uboot-envtools
KERNELNAME:=zImage dtbs