aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch')
-rw-r--r--target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch60
1 files changed, 40 insertions, 20 deletions
diff --git a/target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch b/target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch
index 408da4a3a0..ea144be0f3 100644
--- a/target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch
+++ b/target/linux/omap24xx/patches-3.1/400-bluetooth-hci_h4p.patch
@@ -11,8 +11,10 @@
drivers/bluetooth/hci_h4p/uart.c | 169 +++++
10 files changed, 1891 insertions(+)
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/core.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/core.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/core.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,1043 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1057,8 +1059,10 @@
+MODULE_DESCRIPTION("h4 driver with nokia extensions");
+MODULE_LICENSE("GPL");
+MODULE_AUTHOR("Ville Tervo");
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/fw.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/fw.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/fw.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,155 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1215,8 +1219,10 @@
+
+ return;
+}
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/fw-csr.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/fw-csr.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/fw-csr.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,149 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1367,8 +1373,10 @@
+
+ return 0;
+}
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/fw-ti.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/fw-ti.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/fw-ti.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,90 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1460,8 +1468,10 @@
+
+ return 0;
+}
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/hci_h4p.h
+Index: linux-3.1/drivers/bluetooth/hci_h4p/hci_h4p.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/hci_h4p.h 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,183 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1646,8 +1656,10 @@
+int hci_h4p_init_uart(struct hci_h4p_info *info);
+
+#endif /* __DRIVERS_BLUETOOTH_HCI_H4P_H */
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/Makefile
+Index: linux-3.1/drivers/bluetooth/hci_h4p/Makefile
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/Makefile 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,7 @@
+#
+# Makefile for the Linux Bluetooth HCI device drivers.
@@ -1656,8 +1668,10 @@
+obj-$(CONFIG_BT_HCIH4P) += hci_h4p.o
+
+hci_h4p-objs := core.o fw.o uart.o sysfs.o fw-ti.o fw-csr.o
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/sysfs.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/sysfs.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/sysfs.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,84 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1743,8 +1757,10 @@
+}
+
+#endif
---- /dev/null
-+++ b/drivers/bluetooth/hci_h4p/uart.c
+Index: linux-3.1/drivers/bluetooth/hci_h4p/uart.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.1/drivers/bluetooth/hci_h4p/uart.c 2011-10-30 00:48:52.285041210 +0200
@@ -0,0 +1,169 @@
+/*
+ * This file is part of hci_h4p bluetooth driver
@@ -1915,8 +1931,10 @@
+
+ return 0;
+}
---- a/drivers/bluetooth/Kconfig
-+++ b/drivers/bluetooth/Kconfig
+Index: linux-3.1/drivers/bluetooth/Kconfig
+===================================================================
+--- linux-3.1.orig/drivers/bluetooth/Kconfig 2011-10-30 00:48:29.105057133 +0200
++++ linux-3.1/drivers/bluetooth/Kconfig 2011-10-30 00:48:52.285041210 +0200
@@ -173,6 +173,16 @@ config BT_HCIBTUART
Say Y here to compile support for HCI UART devices into the
kernel or say M to compile it as module (btuart_cs).
@@ -1934,8 +1952,10 @@
config BT_HCIVHCI
tristate "HCI VHCI (Virtual HCI device) driver"
help
---- a/drivers/bluetooth/Makefile
-+++ b/drivers/bluetooth/Makefile
+Index: linux-3.1/drivers/bluetooth/Makefile
+===================================================================
+--- linux-3.1.orig/drivers/bluetooth/Makefile 2011-10-30 00:48:29.141057108 +0200
++++ linux-3.1/drivers/bluetooth/Makefile 2011-10-30 00:48:52.285041210 +0200
@@ -11,6 +11,7 @@ obj-$(CONFIG_BT_HCIDTL1) += dtl1_cs.o
obj-$(CONFIG_BT_HCIBT3C) += bt3c_cs.o
obj-$(CONFIG_BT_HCIBLUECARD) += bluecard_cs.o