aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeontx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/octeontx/Makefile')
-rw-r--r--target/linux/octeontx/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
new file mode 100644
index 0000000000..bbe8149b0b
--- /dev/null
+++ b/target/linux/octeontx/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2018 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=octeontx
+BOARDNAME:=Octeon-TX
+FEATURES:=targz pcie gpio rtc usb
+CFLAGS:=-Os -pipe -fno-caller-saves
+
+MAINTAINER:=Tim Harvey <tharvey@gateworks.com>
+
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+ Build images for Octeon-TX CN80XX/CN81XX based boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=Image
+
+$(eval $(call BuildTarget))