aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/octeon/image/Makefile')
-rw-r--r--target/linux/octeon/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 23adb884f8..fa845a2499 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -84,4 +84,14 @@ define Device/ubnt_edgerouter-lite
endef
TARGET_DEVICES += ubnt_edgerouter-lite
+define Device/ubnt_unifi-usg
+ $(Device/ubnt_edgerouter-lite)
+ DEVICE_MODEL := UniFi Security Gateway
+ BOARD_NAME := ubnt,usg
+ DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio
+ DEVICE_DTS := cn5020_ubnt_usg
+ KERNEL += | append-dtb-to-elf
+endef
+TARGET_DEVICES += ubnt_unifi-usg
+
$(eval $(call BuildImage))