aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh9
-rw-r--r--target/linux/mvebu/image/cortexa72.mk11
3 files changed, 20 insertions, 3 deletions
diff --git a/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network b/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
index f3c59bf2ad..6a5861084e 100644
--- a/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
+++ b/target/linux/mvebu/cortexa72/base-files/etc/board.d/02_network
@@ -29,6 +29,9 @@ marvell,armada8040-db)
marvell,armada7040-db)
ucidef_set_interfaces_lan_wan "eth0 eth2" "eth1"
;;
+marvell,armada8040-clearfog-gt-8k)
+ ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 eth2" "eth0 eth1"
+ ;;
*)
ucidef_set_interface_lan "eth0"
;;
diff --git a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
index 18fdb01959..dc964a3117 100755
--- a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
@@ -13,7 +13,8 @@ platform_check_image() {
iei,puzzle-m901|\
iei,puzzle-m902|\
marvell,armada8040-mcbin-doubleshot|\
- marvell,armada8040-mcbin-singleshot)
+ marvell,armada8040-mcbin-singleshot|\
+ marvell,armada8040-clearfog-gt-8k)
legacy_sdcard_check_image "$1"
;;
*)
@@ -30,7 +31,8 @@ platform_do_upgrade() {
;;
globalscale,mochabin|\
marvell,armada8040-mcbin-doubleshot|\
- marvell,armada8040-mcbin-singleshot)
+ marvell,armada8040-mcbin-singleshot|\
+ marvell,armada8040-clearfog-gt-8k)
legacy_sdcard_do_upgrade "$1"
;;
*)
@@ -44,7 +46,8 @@ platform_copy_config() {
iei,puzzle-m901|\
iei,puzzle-m902|\
marvell,armada8040-mcbin-doubleshot|\
- marvell,armada8040-mcbin-singleshot)
+ marvell,armada8040-mcbin-singleshot|\
+ marvell,armada8040-clearfog-gt-8k)
legacy_sdcard_copy_config
;;
esac
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index f95ce533ea..84ce0cda9a 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -52,6 +52,17 @@ define Device/marvell_macchiatobin-singleshot
endef
TARGET_DEVICES += marvell_macchiatobin-singleshot
+define Device/marvell_clearfog-gt-8k
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := Clearfog
+ DEVICE_VARIANT := GT-8K
+ DEVICE_PACKAGES += kmod-i2c-mux-pca954x kmod-crypto-hw-safexcel
+ DEVICE_DTS := armada-8040-clearfog-gt-8k
+ SUPPORTED_DEVICES := marvell,armada8040-clearfog-gt-8k
+endef
+TARGET_DEVICES += marvell_clearfog-gt-8k
+
define Device/iei_puzzle-m901
$(call Device/Default-arm64)
DEVICE_VENDOR := iEi