aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/patches-3.18/025-ARM-mvebu-Use-arm_coherent_dma_ops.patch2
-rw-r--r--target/linux/mvebu/patches-3.18/202-gpio_mvebu_add_limited_pwm_support.patch2
-rw-r--r--target/linux/mvebu/patches-3.18/209-solidrun_clearfog.patch4
-rw-r--r--target/linux/mvebu/patches-3.18/700-usb_xhci_plat_phy_support.patch4
4 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/mvebu/patches-3.18/025-ARM-mvebu-Use-arm_coherent_dma_ops.patch b/target/linux/mvebu/patches-3.18/025-ARM-mvebu-Use-arm_coherent_dma_ops.patch
index e3d1415ede..4c2ba2322f 100644
--- a/target/linux/mvebu/patches-3.18/025-ARM-mvebu-Use-arm_coherent_dma_ops.patch
+++ b/target/linux/mvebu/patches-3.18/025-ARM-mvebu-Use-arm_coherent_dma_ops.patch
@@ -93,7 +93,7 @@ Signed-off-by: Andrew Lunn <andrew@lunn.ch>
return NOTIFY_OK;
}
-@@ -405,14 +353,9 @@ static int coherency_type(void)
+@@ -399,14 +347,9 @@ static int coherency_type(void)
return type;
}
diff --git a/target/linux/mvebu/patches-3.18/202-gpio_mvebu_add_limited_pwm_support.patch b/target/linux/mvebu/patches-3.18/202-gpio_mvebu_add_limited_pwm_support.patch
index 49a8c0aec1..57c67d169a 100644
--- a/target/linux/mvebu/patches-3.18/202-gpio_mvebu_add_limited_pwm_support.patch
+++ b/target/linux/mvebu/patches-3.18/202-gpio_mvebu_add_limited_pwm_support.patch
@@ -23,7 +23,7 @@ Signed-off-by: Andrew Lunn <andrew@lunn.ch>
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
-@@ -223,6 +223,11 @@ config GPIO_MVEBU
+@@ -224,6 +224,11 @@ config GPIO_MVEBU
select GPIO_GENERIC
select GENERIC_IRQ_CHIP
diff --git a/target/linux/mvebu/patches-3.18/209-solidrun_clearfog.patch b/target/linux/mvebu/patches-3.18/209-solidrun_clearfog.patch
index ff6c2179bc..6df56883ea 100644
--- a/target/linux/mvebu/patches-3.18/209-solidrun_clearfog.patch
+++ b/target/linux/mvebu/patches-3.18/209-solidrun_clearfog.patch
@@ -1,8 +1,8 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -504,6 +504,7 @@ dtb-$(CONFIG_MACH_ARMADA_38X) += \
- armada-385-linksys-caiman.dtb \
+@@ -505,6 +505,7 @@ dtb-$(CONFIG_MACH_ARMADA_38X) += \
armada-385-linksys-cobra.dtb \
+ armada-385-linksys-rango.dtb \
armada-385-linksys-shelby.dtb \
+ armada-388-clearfog.dtb \
armada-385-rd.dtb
diff --git a/target/linux/mvebu/patches-3.18/700-usb_xhci_plat_phy_support.patch b/target/linux/mvebu/patches-3.18/700-usb_xhci_plat_phy_support.patch
index 3ee9f5c990..7631b6c5cd 100644
--- a/target/linux/mvebu/patches-3.18/700-usb_xhci_plat_phy_support.patch
+++ b/target/linux/mvebu/patches-3.18/700-usb_xhci_plat_phy_support.patch
@@ -8,7 +8,7 @@
#include <linux/slab.h>
#include <linux/usb/xhci_pdriver.h>
-@@ -158,12 +159,27 @@ static int xhci_plat_probe(struct platfo
+@@ -161,12 +162,27 @@ static int xhci_plat_probe(struct platfo
if (HCC_MAX_PSA(xhci->hcc_params) >= 4)
xhci->shared_hcd->can_do_streams = 1;
@@ -37,7 +37,7 @@
put_usb3_hcd:
usb_put_hcd(xhci->shared_hcd);
-@@ -187,6 +203,7 @@ static int xhci_plat_remove(struct platf
+@@ -190,6 +206,7 @@ static int xhci_plat_remove(struct platf
struct clk *clk = xhci->clk;
usb_remove_hcd(xhci->shared_hcd);