aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/modules.mk')
-rw-r--r--target/linux/mvebu/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mvebu/modules.mk b/target/linux/mvebu/modules.mk
index 2700e2b159..311cc07c7f 100644
--- a/target/linux/mvebu/modules.mk
+++ b/target/linux/mvebu/modules.mk
@@ -15,3 +15,19 @@ define KernelPackage/linkstation-poweroff/description
endef
$(eval $(call KernelPackage,linkstation-poweroff))
+
+
+define KernelPackage/leds-turris-omnia
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED support for CZ.NIC's Turris Omnia
+ DEPENDS:=@TARGET_mvebu_cortexa9
+ KCONFIG:=CONFIG_LEDS_TURRIS_OMNIA
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-turris-omnia.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-turris-omnia,1)
+endef
+
+define KernelPackage/leds-turris-omnia/description
+ This option enables support for the LEDs of the CZ.NIC Turris Omnia.
+endef
+
+$(eval $(call KernelPackage,leds-turris-omnia))