aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile10
-rw-r--r--target/linux/mvebu/image/cortexa9.mk15
2 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index b0498d34c9..57129d2dcb 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -53,6 +53,16 @@ define Build/buffalo-kernel-jffs2
rm -rf $(KDIR)/kernel_jffs2 $@.fakerd
endef
+define Build/buffalo-kernel-ubifs
+ rm -rf $@-ubidir
+ mkdir -p $@-ubidir
+ mv $@ $@-ubidir/uImage.buffalo
+ touch $@
+ $(call Build/append-uImage-fakehdr, ramdisk)
+ mv $@ $@-ubidir/initrd.buffalo
+ $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(KERNEL_UBIFS_OPTS) -r $@-ubidir $@
+endef
+
# Some info about Ctera firmware:
# 1. It's simple tar file (GNU standard), but it must have ".firm" suffix.
# 2. It contains two images: kernel and romdisk. Both are required.
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index aed1d47646..56381ab5f8 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -14,6 +14,21 @@ define Device/kernel-size-migration
Upgrade via sysupgrade mechanism is not possible, so new installation via factory style image is required.
endef
+define Device/buffalo_ls220de
+ $(Device/NAND-128K)
+ DEVICE_VENDOR := Buffalo
+ DEVICE_MODEL := LinkStation LS220DE
+ KERNEL_UBIFS_OPTS = -m $$(PAGESIZE) -e 124KiB -c 172 -x none
+ KERNEL := kernel-bin | append-dtb | uImage none | buffalo-kernel-ubifs
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+ DEVICE_DTS := armada-370-buffalo-ls220de
+ DEVICE_PACKAGES := \
+ kmod-hwmon-gpiofan kmod-hwmon-drivetemp kmod-linkstation-poweroff \
+ kmod-md-mod kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-fs-xfs \
+ mdadm mkf2fs e2fsprogs partx-utils
+endef
+TARGET_DEVICES += buffalo_ls220de
+
define Device/buffalo_ls421de
$(Device/NAND-128K)
DEVICE_VENDOR := Buffalo