aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile14
-rw-r--r--target/linux/mvebu/image/cortexa9.mk16
2 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index ef9274866d..3a47878069 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -40,6 +40,20 @@ define Build/boot-img-ext4
make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
endef
+define Build/buffalo-kernel-jffs2
+ rm -rf $(KDIR)/kernel_jffs2 $@.fakerd
+ mkdir -p $(KDIR)/kernel_jffs2
+ dd if=/dev/zero of=$@.fakerd bs=131008 count=1 conv=sync
+ $(STAGING_DIR_HOST)/bin/mkimage \
+ -T ramdisk -A $(LINUX_KARCH) -O linux -C gzip -n 'fake initrd' \
+ -d $@.fakerd $(KDIR)/kernel_jffs2/initrd.buffalo
+ cp $@ $(KDIR)/kernel_jffs2/uImage.buffalo
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
+ --little-endian -v --squash-uids -q -f -n -x lzma -x rtime -m none \
+ --eraseblock=128KiB --pad=$(KERNEL_SIZE) -d $(KDIR)/kernel_jffs2 -o $@
+ rm -rf $(KDIR)/kernel_jffs2 $@.fakerd
+endef
+
define Build/sdcard-img
SIGNATURE="$(IMG_PART_SIGNATURE)" \
./gen_mvebu_sdcard_img.sh $@ \
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 85bfa94dbd..4ab6f4a7e8 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -6,6 +6,22 @@
# See /LICENSE for more information.
#
+define Device/buffalo_ls421de
+ $(Device/NAND-128K)
+ DEVICE_VENDOR := Buffalo
+ DEVICE_MODEL := LinkStation LS421DE
+ SUBPAGESIZE :=
+ KERNEL_SIZE := 33554432
+ FILESYSTEMS := squashfs ubifs
+ KERNEL := kernel-bin | append-dtb | uImage none | buffalo-kernel-jffs2
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+ DEVICE_DTS := armada-370-buffalo-ls421de
+ DEVICE_PACKAGES := \
+ kmod-rtc-rs5c372a kmod-hwmon-gpiofan kmod-usb3 kmod-md-raid0 \
+ kmod-md-raid1 kmod-md-mod kmod-fs-xfs mkf2fs e2fsprogs partx-utils
+endef
+TARGET_DEVICES += buffalo_ls421de
+
define Device/cznic_turris-omnia
DEVICE_VENDOR := CZ.NIC
DEVICE_MODEL := Turris Omnia