aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa72.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index 6e52109237..1440c07a0b 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -16,14 +16,30 @@ define Device/marvell_armada8040-db
endef
TARGET_DEVICES += marvell_armada8040-db
-define Device/marvell_macchiatobin
+define Device/marvell_macchiatobin-doubleshot
$(call Device/Default-arm64)
DEVICE_VENDOR := SolidRun
DEVICE_MODEL := MACCHIATObin
+ DEVICE_VARIANT := Double Shot
DEVICE_ALT0_VENDOR := SolidRun
DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_ALT0_VARIANT := Double Shot
DEVICE_PACKAGES += kmod-i2c-mux-pca954x
DEVICE_DTS := armada-8040-mcbin
SUPPORTED_DEVICES := marvell,armada8040-mcbin-doubleshot marvell,armada8040-mcbin
endef
-TARGET_DEVICES += marvell_macchiatobin
+TARGET_DEVICES += marvell_macchiatobin-doubleshot
+
+define Device/marvell_macchiatobin-singleshot
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := MACCHIATObin
+ DEVICE_VARIANT := Single Shot
+ DEVICE_ALT0_VENDOR := SolidRun
+ DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_ALT0_VARIANT := Single Shot
+ DEVICE_PACKAGES += kmod-i2c-mux-pca954x
+ DEVICE_DTS := armada-8040-mcbin-singleshot
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
+endef
+TARGET_DEVICES += marvell_macchiatobin-singleshot