aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 4c7bbcd758..09f3d45e9e 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -65,7 +65,6 @@ define Device/linksys_wrt1200ac
DEVICE_ALT0_MODEL := Caiman
DEVICE_DTS := armada-385-linksys-caiman
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-caiman linksys,caiman
endef
TARGET_DEVICES += linksys_wrt1200ac
@@ -80,11 +79,10 @@ define Device/linksys_wrt1900acs
DEVICE_ALT1_MODEL := Shelby
DEVICE_DTS := armada-385-linksys-shelby
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-shelby linksys,shelby
endef
TARGET_DEVICES += linksys_wrt1900acs
-define Device/linksys_wrt1900ac
+define Device/linksys_wrt1900ac-v1
$(call Device/linksys)
DEVICE_MODEL := WRT1900AC
DEVICE_VARIANT := v1
@@ -93,11 +91,10 @@ define Device/linksys_wrt1900ac
DEVICE_DTS := armada-xp-linksys-mamba
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
KERNEL_SIZE := 3072k
- SUPPORTED_DEVICES := armada-xp-linksys-mamba linksys,mamba
endef
-TARGET_DEVICES += linksys_wrt1900ac
+TARGET_DEVICES += linksys_wrt1900ac-v1
-define Device/linksys_wrt1900acv2
+define Device/linksys_wrt1900ac-v2
$(call Device/linksys)
DEVICE_MODEL := WRT1900AC
DEVICE_VARIANT := v2
@@ -105,9 +102,8 @@ define Device/linksys_wrt1900acv2
DEVICE_ALT0_MODEL := Cobra
DEVICE_DTS := armada-385-linksys-cobra
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-cobra linksys,cobra
endef
-TARGET_DEVICES += linksys_wrt1900acv2
+TARGET_DEVICES += linksys_wrt1900ac-v2
define Device/linksys_wrt3200acm
$(call Device/linksys)
@@ -116,7 +112,6 @@ define Device/linksys_wrt3200acm
DEVICE_ALT0_MODEL := Rango
DEVICE_DTS := armada-385-linksys-rango
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
- SUPPORTED_DEVICES := armada-385-linksys-rango linksys,rango
endef
TARGET_DEVICES += linksys_wrt3200acm
@@ -129,7 +124,6 @@ define Device/linksys_wrt32x
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
KERNEL_SIZE := 3072k
KERNEL := kernel-bin | append-dtb
- SUPPORTED_DEVICES := armada-385-linksys-venom linksys,venom
endef
TARGET_DEVICES += linksys_wrt32x