aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa72.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortexa72.mk')
-rw-r--r--target/linux/mvebu/image/cortexa72.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index 1440c07a0b..29727f8b9d 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -43,3 +43,21 @@ define Device/marvell_macchiatobin-singleshot
SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
endef
TARGET_DEVICES += marvell_macchiatobin-singleshot
+
+define Device/iei_puzzle-m901
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := iEi
+ DEVICE_MODEL := Puzzle-M901
+ SOC := cn9131
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+endef
+TARGET_DEVICES += iei_puzzle-m901
+
+define Device/iei_puzzle-m902
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := iEi
+ DEVICE_MODEL := Puzzle-M902
+ SOC := cn9132
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+endef
+TARGET_DEVICES += iei_puzzle-m902