aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa53.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortexa53.mk')
-rw-r--r--target/linux/mvebu/image/cortexa53.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index b65f25472c..6a3a568655 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -32,6 +32,17 @@ define Device/globalscale_espressobin-emmc
endef
TARGET_DEVICES += globalscale_espressobin-emmc
+define Device/globalscale_espressobin-ultra
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := Marvell
+ DEVICE_MODEL := ESPRESSObin
+ DEVICE_VARIANT := Ultra
+ DEVICE_PACKAGES += kmod-i2c-pxa kmod-rtc-pcf8563
+ SOC := armada-3720
+ BOOT_SCRIPT := espressobin
+endef
+TARGET_DEVICES += globalscale_espressobin-ultra
+
define Device/globalscale_espressobin-v7
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell