aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx')
-rw-r--r--target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts9
-rw-r--r--target/linux/mpc85xx/image/p1020.mk2
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts b/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts
index bb2f2d0827..ccf60eaeed 100644
--- a/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts
+++ b/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts
@@ -24,6 +24,7 @@
led-running = &led_power_green;
led-upgrade = &led_fault_red;
label-mac-device = &enet0;
+ spi0 = &spi0;
};
memory {
@@ -113,6 +114,14 @@
board_soc: soc: soc@ffe00000 {
ranges = <0x0 0x0 0xffe00000 0x100000>;
+ spi0: spi@7000 {
+ temperature-sensor@1 {
+ compatible = "ti,tmp125";
+ reg = <1>;
+ spi-max-frequency = <5000000>;
+ };
+ };
+
i2c@3100 {
tpm@29 {
compatible = "atmel,at97sc3204t";
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index a50b489df1..64cad1ad9c 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -15,7 +15,7 @@ define Device/aerohive_hiveap-330
DEVICE_MODEL := HiveAP-330
DEVICE_ALT0_VENDOR := Aerohive
DEVICE_ALT0_MODEL := HiveAP-350
- DEVICE_PACKAGES := kmod-tpm-i2c-atmel
+ DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-hwmon-lm70
BLOCKSIZE := 128k
KERNEL := kernel-bin | uImage none
KERNEL_INITRAMFS := kernel-bin | MultiImage none