aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch')
-rw-r--r--target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch b/target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch
new file mode 100644
index 0000000000..5844b80f42
--- /dev/null
+++ b/target/linux/mpc85xx/patches-4.19/105-powerpc-85xx-panda-support.patch
@@ -0,0 +1,34 @@
+Index: linux-4.14.82/arch/powerpc/platforms/85xx/Kconfig
+===================================================================
+--- linux-4.14.82.orig/arch/powerpc/platforms/85xx/Kconfig
++++ linux-4.14.82/arch/powerpc/platforms/85xx/Kconfig
+@@ -60,6 +60,17 @@ config HIVEAP_330
+ This board is a Concurrent Dual-Band wireless access point with a
+ Freescale P1020 SoC.
+
++config PANDA
++ bool "OCEDO PANDA"
++ select DEFAULT_UIMAGE
++ select ARCH_REQUIRE_GPIOLIB
++ select GPIO_MPC8XXX
++ help
++ This option enables support for the OCEDO PANDA board.
++
++ This board is a Concurrent Dual-Band wireless access point with a
++ Freescale P1020 SoC.
++
+ config MPC8540_ADS
+ bool "Freescale MPC8540 ADS"
+ select DEFAULT_UIMAGE
+Index: linux-4.14.82/arch/powerpc/platforms/85xx/Makefile
+===================================================================
+--- linux-4.14.82.orig/arch/powerpc/platforms/85xx/Makefile
++++ linux-4.14.82/arch/powerpc/platforms/85xx/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_P1010_RDB) += p1010rdb.o
+ obj-$(CONFIG_P1022_DS) += p1022_ds.o
+ obj-$(CONFIG_P1022_RDK) += p1022_rdk.o
+ obj-$(CONFIG_P1023_RDB) += p1023_rdb.o
++obj-$(CONFIG_PANDA) += panda.o
+ obj-$(CONFIG_TWR_P102x) += twr_p102x.o
+ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
+ obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o