aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/p2020.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/image/p2020.mk')
-rw-r--r--target/linux/mpc85xx/image/p2020.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/p2020.mk b/target/linux/mpc85xx/image/p2020.mk
new file mode 100644
index 0000000000..79b5fa660c
--- /dev/null
+++ b/target/linux/mpc85xx/image/p2020.mk
@@ -0,0 +1,15 @@
+define Device/freescale_p2020rdb
+ DEVICE_VENDOR := Freescale
+ DEVICE_MODEL := P2020RDB
+ DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+ DEVICE_PACKAGES := kmod-hwmon-lm90 kmod-rtc-ds1307 \
+ kmod-gpio-pca953x kmod-eeprom-at24
+ BLOCKSIZE := 128k
+ KERNEL := kernel-bin | gzip | \
+ fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ SUPPORTED_DEVICES := fsl,P2020RDB
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ pad-rootfs $$(BLOCKSIZE) | append-metadata
+endef
+TARGET_DEVICES += freescale_p2020rdb