aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/p1020.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/image/p1020.mk')
-rw-r--r--target/linux/mpc85xx/image/p1020.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index 64cad1ad9c..234bdc26a1 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -68,6 +68,18 @@ define Device/enterasys_ws-ap3710i
endef
TARGET_DEVICES += enterasys_ws-ap3710i
+define Device/extreme-networks_ws-ap3825i
+ DEVICE_VENDOR := Extreme Networks
+ DEVICE_MODEL := WS-AP3825i
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ BLOCKSIZE := 128k
+ DTB_SIZE := 20480
+ KERNEL = kernel-bin | lzma | dtb | fit lzma $(KDIR)/image-$$(DEVICE_DTS).dtb
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += extreme-networks_ws-ap3825i
+
define Device/ocedo_panda
DEVICE_VENDOR := OCEDO
DEVICE_MODEL := Panda