aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index e803cabcbe..57f1fba499 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -90,6 +90,20 @@ define Device/hiveap-330
endef
TARGET_DEVICES += hiveap-330
+define Device/panda
+ DEVICE_TITLE := OCEDO Panda
+ DEVICE_PACKAGES := kmod-rtc-ds1307 kmod-usb2 uboot-envtools
+ KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ BLOCKSIZE := 128k
+ SUPPORTED_DEVICES := ocedo,panda
+ IMAGES := fdt.bin sysupgrade.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/fdt.bin := append-dtb
+endef
+TARGET_DEVICES += panda
+
endif
ifeq ($(SUBTARGET),p2020)