aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 7cbf733852..e803cabcbe 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -58,6 +58,18 @@ define Device/tl-wdr4900-v1
endef
TARGET_DEVICES += tl-wdr4900-v1
+define Device/red-15w-rev1
+ DEVICE_TITLE := Sophos RED 15w Rev.1
+ DEVICE_PACKAGES := kmod-usb2
+ # Original firmware uses a dedicated DTB-partition.
+ # The bootloader however supports FIT-images.
+ KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
+ SUPPORTED_DEVICES := sophos,red-15w-rev1
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += red-15w-rev1
+
endif
ifeq ($(SUBTARGET),p1020)