aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc52xx')
-rw-r--r--target/linux/mpc52xx/Makefile2
-rw-r--r--target/linux/mpc52xx/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
index 0000c34642..d3cf6a2950 100644
--- a/target/linux/mpc52xx/Makefile
+++ b/target/linux/mpc52xx/Makefile
@@ -20,4 +20,6 @@ define Target/Description
Build images for the Freescale MPC52xx based boards.
endef
+KERNELNAME:="zImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/mpc52xx/image/Makefile b/target/linux/mpc52xx/image/Makefile
index b63a78dc57..fc7e9cdce6 100644
--- a/target/linux/mpc52xx/image/Makefile
+++ b/target/linux/mpc52xx/image/Makefile
@@ -7,10 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/Prepare
- cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
-endef
-
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef