aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/modules.mk')
-rw-r--r--target/linux/mediatek/modules.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/mediatek/modules.mk b/target/linux/mediatek/modules.mk
index eb81afe235..9c6fb515f4 100644
--- a/target/linux/mediatek/modules.mk
+++ b/target/linux/mediatek/modules.mk
@@ -15,6 +15,18 @@ endef
$(eval $(call KernelPackage,ata-ahci-mtk))
+define KernelPackage/btmtkuart
+ SUBMENU:=Other modules
+ TITLE:=MediaTek HCI UART driver
+ DEPENDS:=@TARGET_mediatek_mt7622 +kmod-bluetooth +mt7622bt-firmware
+ KCONFIG:=CONFIG_BT_MTKUART
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/btmtkuart.ko
+ AUTOLOAD:=$(call AutoProbe,btmtkuart)
+endef
+
+$(eval $(call KernelPackage,btmtkuart))
+
define KernelPackage/sdhci-mtk
SUBMENU:=Other modules
TITLE:=Mediatek SDHCI driver