aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/mt7622.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 0d8af5a9ee..0aea5dc488 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -16,3 +16,14 @@ define Device/bpi_bananapi-r64
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
endef
TARGET_DEVICES += bpi_bananapi-r64
+
+define Device/elecom-wrc-2533gent
+ DEVICE_VENDOR := Elecom
+ DEVICE_MODEL := Elecom WRC-2533GENT
+ DEVICE_DTS := mt7622-elecom-wrc-2533gent
+ DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 \
+ kmod-mt7615e mt7622bt-firmware swconfig
+ SUPPORTED_DEVICES := elecom,wrc-2533gent
+endef
+TARGET_DEVICES += elecom-wrc-2533gent