aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/filogic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/image/filogic.mk')
-rw-r--r--target/linux/mediatek/image/filogic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index ae25aee2ed..fd83b9d441 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -250,6 +250,20 @@ define Device/mediatek_mt7988a-rfb-nand
endef
TARGET_DEVICES += mediatek_mt7988a-rfb-nand
+define Device/mercusys_mr90x-v1
+ DEVICE_VENDOR := Mercusys
+ DEVICE_MODEL := MR90X v1
+ DEVICE_DTS := mt7986b-mercusys-mr90x-v1
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := kmod-mt7986-firmware mt7986-wo-firmware
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 51200k
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += mercusys_mr90x-v1
+
define Device/qihoo_360t7
DEVICE_VENDOR := Qihoo
DEVICE_MODEL := 360T7