aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/image/Makefile')
-rw-r--r--target/linux/mediatek/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
index 97164428e0..d4f79ec974 100644
--- a/target/linux/mediatek/image/Makefile
+++ b/target/linux/mediatek/image/Makefile
@@ -6,6 +6,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+DEVICE_VARS += NETGEAR_ENC_MODEL NETGEAR_ENC_REGION NETGEAR_ENC_HW_ID_LIST NETGEAR_ENC_MODEL_LIST
+
loadaddr-$(CONFIG_TARGET_mediatek_mt7622) := 0x44000000
loadaddr-$(CONFIG_TARGET_mediatek_mt7623) := 0x80008000
loadaddr-$(CONFIG_TARGET_mediatek_mt7629) := 0x40008000
@@ -22,6 +24,10 @@ define Device/Default
KERNEL_LOADADDR = $(loadaddr-y)
FILESYSTEMS := squashfs
DEVICE_DTS_DIR := $(DTS_DIR)
+ NETGEAR_ENC_MODEL :=
+ NETGEAR_ENC_REGION :=
+ NETGEAR_ENC_HW_ID_LIST :=
+ NETGEAR_ENC_MODEL_LIST :=
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
pad-rootfs | append-metadata