aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch119
1 files changed, 0 insertions, 119 deletions
diff --git a/target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch b/target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch
deleted file mode 100644
index 311d73b475..0000000000
--- a/target/linux/layerscape/patches-5.4/302-dts-0116-LF-881-arm64-dts-add-a-dts-file-for-dpdk.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From f0f46229b2232595a1afde10f6f17e512c004042 Mon Sep 17 00:00:00 2001
-From: Gagandeep Singh <g.singh@nxp.com>
-Date: Thu, 6 Feb 2020 13:01:10 +0000
-Subject: [PATCH] LF-881: arm64: dts: add a dts file for dpdk
-
-A new device tree file fsl-ls1028a-rdb-dpdk.dts is added
-for user space networking.
-
-Signed-off-by: Gagandeep Singh <g.singh@nxp.com>
-Reviewed-by: Alex Marginean <alexandru.marginean@nxp.com>
-Reviewed-by: Li Yang <leoyang.li@nxp.com>
----
- arch/arm64/boot/dts/freescale/Makefile | 1 +
- .../boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts | 89 ++++++++++++++++++++++
- 2 files changed, 90 insertions(+)
- create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts
-
---- a/arch/arm64/boot/dts/freescale/Makefile
-+++ b/arch/arm64/boot/dts/freescale/Makefile
-@@ -23,6 +23,7 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-qds-899b.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-qds-9999.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-rdb.dtb
-+dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1028a-rdb-dpdk.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-qds.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-qds-sdk.dtb
- dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-rdb.dtb
---- /dev/null
-+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a-rdb-dpdk.dts
-@@ -0,0 +1,89 @@
-+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
-+/*
-+ * NXP LS1028A RDB Board device tree file for DPDK
-+ *
-+ * Copyright 2018-2020 NXP
-+ */
-+
-+/dts-v1/;
-+#include "fsl-ls1028a-rdb.dts"
-+
-+&enetc_port0 {
-+ status = "okay";
-+ /delete-property/ phy-handle;
-+ /delete-property/ phy-connection-type;
-+ /delete-node/ mdio;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+};
-+
-+/delete-node/ &enetc_mdio_pf3;
-+
-+/* l2switch ports */
-+&mscc_felix_ports {
-+ port@0 {
-+ status = "okay";
-+ phy-mode = "qsgmii";
-+ /delete-property/ managed;
-+ /delete-property/ phy-handle;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+ };
-+
-+ port@1 {
-+ status = "okay";
-+ phy-mode = "qsgmii";
-+ /delete-property/ managed;
-+ /delete-property/ phy-handle;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+ };
-+
-+ port@2 {
-+ status = "okay";
-+ phy-mode = "qsgmii";
-+ /delete-property/ managed;
-+ /delete-property/ phy-handle;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+ };
-+
-+ port@3 {
-+ status = "okay";
-+ phy-mode = "qsgmii";
-+ /delete-property/ managed;
-+ /delete-property/ phy-handle;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+ };
-+
-+ port@5 {
-+ status = "okay";
-+ /delete-property/ managed;
-+ /delete-property/ phy-handle;
-+
-+ fixed-link {
-+ speed = <1000>;
-+ full-duplex;
-+ };
-+ };
-+};
-+
-+&enetc_port3 {
-+ status = "okay";
-+};