aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch')
-rw-r--r--target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch b/target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch
new file mode 100644
index 0000000000..9b580b4730
--- /dev/null
+++ b/target/linux/layerscape/patches-4.4/3117-armv8-aarch32-Run-32-bit-Linux-for-LayerScape-SoCs.patch
@@ -0,0 +1,49 @@
+From f6dcf8936845ea95eba432ee725cec761032fe2a Mon Sep 17 00:00:00 2001
+From: Ying Zhang <ying.zhang22455@nxp.com>
+Date: Thu, 29 Sep 2016 10:12:29 +0800
+Subject: [PATCH 117/124] armv8: aarch32: Run 32-bit Linux for LayerScape SoCs
+
+This patch adds AArch32 execution state support for LayerScape SoCs.
+
+Signed-off-by: Ebony Zhu <ebony.zhu@nxp.com>
+Signed-off-by: Alison Wang <alison.wang@nxp.com>
+---
+ arch/arm/mach-imx/Makefile | 2 ++
+ arch/arm/mach-imx/mach-layerscape.c | 22 ++++++++++++++++++++++
+ 2 files changed, 24 insertions(+)
+ create mode 100644 arch/arm/mach-imx/mach-layerscape.c
+
+--- a/arch/arm/mach-imx/Makefile
++++ b/arch/arm/mach-imx/Makefile
+@@ -103,4 +103,6 @@ obj-$(CONFIG_SOC_LS1021A) += mach-ls1021
+
+ obj-$(CONFIG_ARCH_LAYERSCAPE) += mach-ls1043a.o
+
++obj-$(CONFIG_ARCH_LAYERSCAPE) += mach-layerscape.o
++
+ obj-y += devices/
+--- /dev/null
++++ b/arch/arm/mach-imx/mach-layerscape.c
+@@ -0,0 +1,22 @@
++/*
++ * Copyright 2015-2016 Freescale Semiconductor, Inc.
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 2 of the License, or
++ * (at your option) any later version.
++ */
++
++#include <asm/mach/arch.h>
++
++#include "common.h"
++
++static const char * const layerscape_dt_compat[] __initconst = {
++ "fsl,ls1043a",
++ "fsl,ls1012a",
++ NULL,
++};
++
++DT_MACHINE_START(LAYERSCAPE, "Freescale LAYERSCAPE")
++ .dt_compat = layerscape_dt_compat,
++MACHINE_END