aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/modules.mk')
-rw-r--r--target/linux/layerscape/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
new file mode 100644
index 0000000000..0b34f96b33
--- /dev/null
+++ b/target/linux/layerscape/modules.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) Jiang Yutang <jiangyutang1978@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ppfe
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Freescale PPFE Driver support
+ KCONFIG:=CONFIG_FSL_PPFE
+ FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
+ AUTOLOAD:=$(call AutoLoad,35,ppfe)
+endef
+
+define KernelPackage/ppfe/description
+ Kernel modules for Freescale PPFE Driver support.
+endef
+
+$(eval $(call KernelPackage,ppfe))