aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile13
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk32
2 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 52dc532c34..1463a3eaea 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -64,6 +64,19 @@ define Build/traverse-fit
@mv -f $@.new $@
endef
+define Build/traverse-fit-ls1088
+ ./mkits-multiple-config.sh -o $@.its -A $(LINUX_KARCH) \
+ -v $(LINUX_VERSION) -k $@ -a $(KERNEL_LOADADDR) \
+ -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -C gzip -c 1 -c 2 \
+ -d $(DTS_DIR)/freescale/fsl-ls1088a-ten64.dtb \
+ -D "TEN64" -n "ten64" -a $(FDT_LOADADDR) -c 1 \
+ -d $(DTS_DIR)/freescale/fsl-ls1088a-rdb.dtb \
+ -D "LS1088ARDB" -n "ls1088ardb" -a $(FDT_LOADADDR) -c 2
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
+ @mv -f $@.new $@
+endef
+
define Device/fix-sysupgrade
DEVICE_COMPAT_VERSION := 2.0
DEVICE_COMPAT_MESSAGE := DTB was added to sysupgrade. Image format is different. \
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index f5a6a055fb..0016e3bde8 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -451,3 +451,35 @@ define Device/traverse_ls1043
SUPPORTED_DEVICES := traverse,ls1043s traverse,ls1043v
endef
TARGET_DEVICES += traverse_ls1043
+
+define Device/traverse_ten64_mtd
+ DEVICE_VENDOR := Traverse
+ DEVICE_MODEL := Ten64 (NAND boot)
+ DEVICE_NAME := ten64-mtd
+ DEVICE_PACKAGES += \
+ uboot-envtools \
+ kmod-rtc-rx8025 \
+ kmod-sfp \
+ kmod-i2c-mux-pca954x \
+ restool
+ DEVICE_DESCRIPTION = \
+ Generate images for booting from NAND/ubifs on Traverse Ten64 (LS1088A) \
+ family boards. For disk (NVMe/USB/SD) boot, use the armvirt target instead.
+ FILESYSTEMS := squashfs
+ KERNEL_LOADADDR := 0x80000000
+ KERNEL_ENTRY_POINT := 0x80000000
+ FDT_LOADADDR := 0x90000000
+ KERNEL_SUFFIX := -kernel.itb
+ DEVICE_DTS := freescale/fsl-ls1088a-ten64
+ IMAGES := nand.ubi sysupgrade.bin
+ KERNEL := kernel-bin | gzip | traverse-fit-ls1088 gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb $$(FDT_LOADADDR)
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/nand.ubi := append-ubi
+ KERNEL_IN_UBI := 1
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 600
+ SUPPORTED_DEVICES = traverse,ten64
+endef
+TARGET_DEVICES += traverse_ten64_mtd
+