aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile4
-rw-r--r--target/linux/layerscape/image/armv7.mk31
2 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 92b3ee0709..b275ef71cc 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -43,4 +43,8 @@ ifeq ($(SUBTARGET),armv8_32b)
include armv8_32b.mk
endif
+ifeq ($(SUBTARGET),armv7)
+include armv7.mk
+endif
+
$(eval $(call BuildImage))
diff --git a/target/linux/layerscape/image/armv7.mk b/target/linux/layerscape/image/armv7.mk
new file mode 100644
index 0000000000..59cc982017
--- /dev/null
+++ b/target/linux/layerscape/image/armv7.mk
@@ -0,0 +1,31 @@
+#
+# Copyright 2018 NXP
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Device/Default
+ PROFILES := Default
+ FILESYSTEMS := squashfs
+ IMAGES := firmware.bin
+ KERNEL := kernel-bin | uImage none
+ KERNEL_NAME := zImage
+ KERNEL_LOADADDR := 0x80008000
+ KERNEL_ENTRY_POINT := 0x80008000
+endef
+
+define Device/ls1021atwr
+ DEVICE_TITLE := LS1021ATWR
+ DEVICE_PACKAGES += layerscape-rcw-ls1021atwr
+ DEVICE_DTS := ls1021a-twr
+ IMAGE/firmware.bin := \
+ ls-clean | \
+ ls-append $(1)-rcw.bin | pad-to 1M | \
+ ls-append $(1)-uboot.bin | pad-to 3M | \
+ ls-append $(1)-uboot-env.bin | pad-to 15M | \
+ ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size 67108865
+endef
+TARGET_DEVICES += ls1021atwr