aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/image/Makefile')
-rw-r--r--target/linux/layerscape/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 52dc532c34..1463a3eaea 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -64,6 +64,19 @@ define Build/traverse-fit
@mv -f $@.new $@
endef
+define Build/traverse-fit-ls1088
+ ./mkits-multiple-config.sh -o $@.its -A $(LINUX_KARCH) \
+ -v $(LINUX_VERSION) -k $@ -a $(KERNEL_LOADADDR) \
+ -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -C gzip -c 1 -c 2 \
+ -d $(DTS_DIR)/freescale/fsl-ls1088a-ten64.dtb \
+ -D "TEN64" -n "ten64" -a $(FDT_LOADADDR) -c 1 \
+ -d $(DTS_DIR)/freescale/fsl-ls1088a-rdb.dtb \
+ -D "LS1088ARDB" -n "ls1088ardb" -a $(FDT_LOADADDR) -c 2
+ PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new
+ @mv -f $@.new $@
+endef
+
define Device/fix-sysupgrade
DEVICE_COMPAT_VERSION := 2.0
DEVICE_COMPAT_MESSAGE := DTB was added to sysupgrade. Image format is different. \