aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/layerscape/image/Makefile')
-rw-r--r--target/linux/layerscape/image/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 8a38a25041..08864b1316 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -11,8 +11,8 @@ LS_SD_ROOTFSPART_OFFSET = 64
LS_SD_IMAGE_SIZE = $(shell echo $$((($(LS_SD_ROOTFSPART_OFFSET) + \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)) * 1024 * 1024)))
-# The limitation of flash sysupgrade.bin is 16MB kernel + 32MB rootfs
-LS_SYSUPGRADE_IMAGE_SIZE = 48m
+# The limitation of flash sysupgrade.bin is 1MB dtb + 16MB kernel + 32MB rootfs
+LS_SYSUPGRADE_IMAGE_SIZE = 49m
define Build/ls-clean
rm -f $@
@@ -46,6 +46,13 @@ define Build/traverse-fit
@mv -f $@.new $@
endef
+define Device/fix-sysupgrade
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := DTB was added to sysupgrade. Image format is different. \
+ To use sysupgrade You need to change firmware partition in bootargs to "49m@0xf00000(firmware)" and saveenv. \
+ After that, You can use "sysupgrade -F".
+endef
+
include $(SUBTARGET).mk
$(eval $(call BuildImage))