aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/config-default3
-rw-r--r--target/linux/lantiq/xway/profiles/003-netgear.mk11
2 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
index dd59fa68d2..5ef2fb3463 100644
--- a/target/linux/lantiq/xway/config-default
+++ b/target/linux/lantiq/xway/config-default
@@ -26,9 +26,9 @@ CONFIG_INPUT_POLLDEV=y
CONFIG_LANTIQ_ETOP=y
CONFIG_LANTIQ_MACH_ARV45XX=y
CONFIG_LANTIQ_MACH_EASY50712=y
+CONFIG_LANTIQ_MACH_NETGEAR=y
CONFIG_MACH_NO_WESTBRIDGE=y
# CONFIG_MINIX_FS_NATIVE_ENDIAN is not set
-# CONFIG_MTD_LATCH_ADDR is not set
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_PER_CPU_KM=y
CONFIG_PCI=y
@@ -44,6 +44,7 @@ CONFIG_SOC_XWAY=y
CONFIG_SPI=y
CONFIG_SPI_BITBANG=y
# CONFIG_SPI_GPIO is not set
+CONFIG_SPI_LANTIQ=y
CONFIG_SPI_MASTER=y
CONFIG_USB_SUPPORT=y
CONFIG_XZ_DEC=y
diff --git a/target/linux/lantiq/xway/profiles/003-netgear.mk b/target/linux/lantiq/xway/profiles/003-netgear.mk
new file mode 100644
index 0000000000..51a98bb2d4
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/003-netgear.mk
@@ -0,0 +1,11 @@
+define Profile/DGN3500B
+ NAME:=DGN3500B
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio
+endef
+
+define Profile/DGN3500B/Description
+ Netgear DGN3500B
+endef
+
+$(eval $(call Profile,DGN3500B))
+