aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.10/0101-timer-backport.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.10/0101-timer-backport.patch')
-rw-r--r--target/linux/lantiq/patches-3.10/0101-timer-backport.patch13
1 files changed, 1 insertions, 12 deletions
diff --git a/target/linux/lantiq/patches-3.10/0101-timer-backport.patch b/target/linux/lantiq/patches-3.10/0101-timer-backport.patch
index 008be43011..7f3e8ff7f3 100644
--- a/target/linux/lantiq/patches-3.10/0101-timer-backport.patch
+++ b/target/linux/lantiq/patches-3.10/0101-timer-backport.patch
@@ -12,9 +12,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 arch/mips/include/asm/mach-lantiq/lantiq_timer.h
create mode 100644 arch/mips/lantiq/xway/timer.c
-diff --git a/arch/mips/include/asm/mach-lantiq/lantiq_timer.h b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
-new file mode 100644
-index 0000000..ef564ab
--- /dev/null
+++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
@@ -0,0 +1,155 @@
@@ -173,19 +170,14 @@ index 0000000..ef564ab
+ u32 reload, unsigned long arg1, unsigned long arg2);
+
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
-diff --git a/arch/mips/lantiq/xway/Makefile b/arch/mips/lantiq/xway/Makefile
-index a2edc53..da51fe0 100644
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
@@ -1,4 +1,4 @@
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
- obj-y += vmmc.o
+ obj-y += vmmc.o mtd_split.o
-diff --git a/arch/mips/lantiq/xway/timer.c b/arch/mips/lantiq/xway/timer.c
-new file mode 100644
-index 0000000..1c0fdb8
--- /dev/null
+++ b/arch/mips/lantiq/xway/timer.c
@@ -0,0 +1,845 @@
@@ -1034,6 +1026,3 @@ index 0000000..1c0fdb8
+module_exit(lq_gptu_exit);
+
+#endif
---
-1.7.10.4
-