aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile2
-rw-r--r--target/linux/lantiq/image/vr9.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0ec04af6b3..87a4110f7e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -52,6 +52,7 @@ define Build/fullimage
rm $@.tmp
endef
+DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
DTS_DIR := $(DTS_DIR)/lantiq
# Shared device definition: applies to every defined device
@@ -93,7 +94,6 @@ define Device/lantiqBrnImage
IMAGES := factory.bin
IMAGE/factory.bin := mkbrnimg | check-size $$$$(IMAGE_SIZE)
endef
-DEVICE_VARS += SIGNATURE MAGIC CRC32_POLY
define Device/lantiqFullImage
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-offset 4 0
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index 083d8efe0f..2bea40011d 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -1,3 +1,5 @@
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+
define Device/alphanetworks_asl56026
DEVICE_VENDOR := Alpha
DEVICE_MODEL := ASL56026
@@ -199,7 +201,6 @@ define Device/netgear_dm200
NETGEAR_BOARD_ID := DM200
NETGEAR_HW_ID := 29765233+8+0+64+0+0
endef
-DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
TARGET_DEVICES += netgear_dm200
define Device/zyxel_p-2812hnu-f1