aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile81
1 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2e0fdb3055..490bd543e0 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -565,4 +565,85 @@ TARGET_DEVICES += VGV7519BRN
endif
+
+ifeq ($(SUBTARGET),falcon)
+
+define Device/EASY98000
+ IMAGE_SIZE := 3904k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board NOR
+ DEVICE_DTS := EASY98000NOR
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000
+
+define Device/EASY98000NAND
+ IMAGE_SIZE := 3904k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board NAND
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000NAND
+
+define Device/EASY98000SFLASH
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98000 - Lantiq Falcon Eval Board SFLASH
+ DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+endef
+TARGET_DEVICES += EASY98000SFLASH
+
+define Device/FALCON-MDU
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := MDU - Lantiq Falcon / VINAXdp MDU Board
+endef
+TARGET_DEVICES += FALCON-MDU
+
+define Device/EASY88388
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY88388 - Lantiq Falcon FTTDP8 Reference Board
+endef
+TARGET_DEVICES += EASY88388
+
+define Device/EASY88444
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY88444 - Lantiq Falcon FTTdp G.FAST Reference Board
+endef
+TARGET_DEVICES += EASY88444
+
+define Device/FALCON-SFP
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := SFP - Lantiq Falcon SFP Stick
+endef
+TARGET_DEVICES += FALCON-SFP
+
+define Device/EASY98035SYNCE
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98035SYNCE - Lantiq Falcon SFP Stick with Synchronous Ethernet
+endef
+TARGET_DEVICES += EASY98035SYNCE
+
+define Device/EASY98035SYNCE1588
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98035SYNCE1588 - Lantiq Falcon SFP Stick with SyncE and IEEE1588
+endef
+TARGET_DEVICES += EASY98035SYNCE1588
+
+define Device/EASY98020
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98020 - Lantiq Falcon SFU Reference Board
+endef
+TARGET_DEVICES += EASY98020
+
+define Device/EASY98020V18
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98020V18 - Lantiq Falcon SFU Reference Board V1.8
+endef
+TARGET_DEVICES += EASY98020V18
+
+define Device/EASY98021
+ IMAGE_SIZE := 7424k
+ DEVICE_TITLE := EASY98021 - Lantiq Falcon HGU Reference Board
+endef
+TARGET_DEVICES += EASY98021
+
+endif
+
$(eval $(call BuildImage))