aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ase/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/ase/target.mk')
-rw-r--r--target/linux/lantiq/ase/target.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644
index 0000000000..5f6c03b38e
--- /dev/null
+++ b/target/linux/lantiq/ase/target.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 LEDE Project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs atm mips16 small_flash
+CPU_TYPE:=mips32
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+ kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+ ltq-adsl-app ppp-mod-pppoe
+
+define Target/Description
+ Lantiq Amazon-SE Boards
+endef