aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/Makefile')
-rw-r--r--target/linux/lantiq/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
new file mode 100644
index 0000000000..5afe5662da
--- /dev/null
+++ b/target/linux/lantiq/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=lantiq
+BOARDNAME:=Lantiq GPON/XWAY
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=xway
+
+LINUX_VERSION:=2.6.35.9
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Lantiq SoC
+endef
+
+$(eval $(call BuildTarget))