aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood')
-rwxr-xr-xtarget/linux/kirkwood/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/kirkwood/base-files/etc/diag.sh3
-rw-r--r--target/linux/kirkwood/image/Makefile7
-rw-r--r--target/linux/kirkwood/patches-4.9/109-pogoplug_v4.patch59
4 files changed, 71 insertions, 1 deletions
diff --git a/target/linux/kirkwood/base-files/etc/board.d/02_network b/target/linux/kirkwood/base-files/etc/board.d/02_network
index b83d0d25cc..0b760fc165 100755
--- a/target/linux/kirkwood/base-files/etc/board.d/02_network
+++ b/target/linux/kirkwood/base-files/etc/board.d/02_network
@@ -16,7 +16,8 @@ case "$board" in
"seagate,goflexnet"|\
"raidsonic,ib-nas62x0"|\
"iom,iconnect-1.1"|\
-"cloudengines,pogoe02")
+"cloudengines,pogoe02"|\
+"cloudengines,pogoplugv4")
ucidef_set_interface_lan "eth0" "dhcp"
;;
"linksys,audi"|\
diff --git a/target/linux/kirkwood/base-files/etc/diag.sh b/target/linux/kirkwood/base-files/etc/diag.sh
index 0ff2ccb17a..ec9eead70d 100755
--- a/target/linux/kirkwood/base-files/etc/diag.sh
+++ b/target/linux/kirkwood/base-files/etc/diag.sh
@@ -14,6 +14,9 @@ get_status_led() {
cloudengines,pogoe02)
status_led="pogo_e02:orange:fault"
;;
+ cloudengines,pogoplugv4)
+ status_led="pogoplugv4:green:health"
+ ;;
linksys,audi)
status_led="audi:green:power"
;;
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index aceeb9b576..f04c0323fb 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -121,6 +121,13 @@ define Device/cloudengines_pogoe02
endef
TARGET_DEVICES += cloudengines_pogoe02
+define Device/cloudengines_pogoplugv4
+ DEVICE_TITLE := Cloud Engines Pogoplug V4
+ DEVICE_DTS := kirkwood-pogoplug-series-4
+ DEVICE_PACKAGES := kmod-usb3
+endef
+TARGET_DEVICES += cloudengines_pogoplugv4
+
define Device/raidsonic_ib-nas62x0
DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
DEVICE_DTS := kirkwood-ib62x0
diff --git a/target/linux/kirkwood/patches-4.9/109-pogoplug_v4.patch b/target/linux/kirkwood/patches-4.9/109-pogoplug_v4.patch
new file mode 100644
index 0000000000..dff1966d5c
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.9/109-pogoplug_v4.patch
@@ -0,0 +1,59 @@
+--- a/arch/arm/boot/dts/kirkwood-pogoplug-series-4.dts
++++ b/arch/arm/boot/dts/kirkwood-pogoplug-series-4.dts
+@@ -23,6 +23,7 @@
+ };
+
+ chosen {
++ bootargs = "console=ttyS0,115200";
+ stdout-path = "uart0:115200n8";
+ };
+
+@@ -36,8 +37,8 @@
+ eject {
+ debounce_interval = <50>;
+ wakeup-source;
+- linux,code = <KEY_EJECTCD>;
+- label = "Eject Button";
++ linux,code = <KEY_RESTART>;
++ label = "Reset";
+ gpios = <&gpio0 29 GPIO_ACTIVE_LOW>;
+ };
+ };
+@@ -136,29 +137,19 @@
+ #size-cells = <1>;
+
+ partition@0 {
+- label = "u-boot";
+- reg = <0x00000000 0x200000>;
++ label = "uboot";
++ reg = <0x00000000 0x1c0000>;
+ read-only;
+ };
+
+- partition@200000 {
+- label = "uImage";
+- reg = <0x00200000 0x300000>;
+- };
+-
+- partition@500000 {
+- label = "uImage2";
+- reg = <0x00500000 0x300000>;
++ partition@1c0000 {
++ label = "uboot_env";
++ reg = <0x001c0000 0x40000>;
+ };
+
+- partition@800000 {
+- label = "failsafe";
+- reg = <0x00800000 0x800000>;
+- };
+-
+- partition@1000000 {
+- label = "root";
+- reg = <0x01000000 0x7000000>;
++ partition@200000 {
++ label = "ubi";
++ reg = <0x00200000 0x7e00000>;
+ };
+ };
+ };