aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index b75ef9fbb2..20b368f709 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -30,18 +30,21 @@ endef
define Device/dockstar
DEVICE_DTS := kirkwood-dockstar
DEVICE_TITLE := Seagate FreeAgent Dockstar
+ SUPPORTED_DEVICES += seagate,dockstar
endef
TARGET_DEVICES += dockstar
define Device/goflexnet
DEVICE_TITLE := Seagate GoFlexNet
DEVICE_DTS := kirkwood-goflexnet
+ SUPPORTED_DEVICES += seagate,goflexnet
endef
TARGET_DEVICES += goflexnet
define Device/goflexhome
DEVICE_TITLE := Seagate GoFlexHome
DEVICE_DTS := kirkwood-goflexhome
+ SUPPORTED_DEVICES += seagate,goflexhome
endef
TARGET_DEVICES += goflexhome
@@ -53,6 +56,7 @@ define Device/linksys-audi
KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ SUPPORTED_DEVICES += linksys,audi
endef
TARGET_DEVICES += linksys-audi
@@ -64,12 +68,14 @@ define Device/linksys-viper
KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ SUPPORTED_DEVICES += linksys,viper
endef
TARGET_DEVICES += linksys-viper
define Device/iconnect
DEVICE_TITLE := Iomega Iconnect
DEVICE_DTS := kirkwood-iconnect
+ SUPPORTED_DEVICES += iom,iconnect-1.1
endef
TARGET_DEVICES += iconnect
@@ -77,6 +83,7 @@ define Device/nsa310b
DEVICE_TITLE := ZyXEL NSA310b
DEVICE_DTS := kirkwood-nsa310b
DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+ SUPPORTED_DEVICES += zyxel,nsa310b
endef
TARGET_DEVICES += nsa310b
@@ -84,6 +91,7 @@ define Device/nsa325
DEVICE_TITLE := ZyXEL NSA325 (v1 and v2)
DEVICE_DTS := kirkwood-nsa325
DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+ SUPPORTED_DEVICES += zyxel,nsa325
endef
TARGET_DEVICES += nsa325
@@ -95,18 +103,21 @@ define Device/on100
KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ SUPPORTED_DEVICES := cisco,on100
endef
TARGET_DEVICES += on100
define Device/pogo_e02
DEVICE_TITLE := Cloud Engines Pogoplug E02
DEVICE_DTS := kirkwood-pogo_e02
+ SUPPORTED_DEVICES += cloudengines,pogoe02
endef
TARGET_DEVICES += pogo_e02
define Device/ib62x0
DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
DEVICE_DTS := kirkwood-ib62x0
+ SUPPORTED_DEVICES += raidsonic,ib-nas62x0
endef
TARGET_DEVICES += ib62x0