aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/image/Makefile')
-rw-r--r--target/linux/kirkwood/image/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index c2c5bcab8f..f1cd2611d2 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -7,9 +7,12 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR:=0x8000
-define Device/dsa-migration
- DEVICE_COMPAT_VERSION := 1.1
- DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+define Device/kernel-size-migration
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partition design has changed compared to \
+ older versions (up to 21.02) due to kernel size restrictions. \
+ Upgrade via sysupgrade mechanism is not possible, so new \
+ installation via factory style image is required.
endef
define Device/Default
@@ -110,31 +113,31 @@ endef
define Device/linksys_e4200-v2
$(Device/linksys)
- $(Device/dsa-migration)
+ $(Device/kernel-size-migration)
DEVICE_MODEL := E4200
DEVICE_VARIANT := v2
- KERNEL_SIZE := 2688k
+ KERNEL_SIZE := 3072k
SUPPORTED_DEVICES += linksys,viper linksys-viper
endef
TARGET_DEVICES += linksys_e4200-v2
define Device/linksys_ea3500
$(Device/linksys)
- $(Device/dsa-migration)
+ $(Device/kernel-size-migration)
DEVICE_MODEL := EA3500
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16k
- KERNEL_SIZE := 2624k
+ KERNEL_SIZE := 3072k
SUPPORTED_DEVICES += linksys,audi linksys-audi
endef
TARGET_DEVICES += linksys_ea3500
define Device/linksys_ea4500
$(Device/linksys)
- $(Device/dsa-migration)
+ $(Device/kernel-size-migration)
DEVICE_MODEL := EA4500
- KERNEL_SIZE := 2688k
+ KERNEL_SIZE := 3072k
SUPPORTED_DEVICES += linksys,viper linksys-viper
endef
TARGET_DEVICES += linksys_ea4500