aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch')
-rw-r--r--target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch38
1 files changed, 14 insertions, 24 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch b/target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch
index 6326db1acd..689d7a3c70 100644
--- a/target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.25/120-compex_support.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-@@ -65,6 +65,14 @@ config MACH_PRONGHORNMETRO
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -65,6 +65,14 @@
Engineering Pronghorn Metro Platform. For more
information on this platform, see <file:Documentation/arm/IXP4xx>.
@@ -17,11 +15,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
config ARCH_IXDP425
bool "IXDP425"
help
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-@@ -17,6 +17,7 @@ obj-pci-$(CONFIG_MACH_GATEWAY7001) += ga
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -17,6 +17,7 @@
obj-pci-$(CONFIG_MACH_WG302V2) += wg302v2-pci.o
obj-pci-$(CONFIG_MACH_FSG) += fsg-pci.o
obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
obj-y += common.o
-@@ -32,6 +33,7 @@ obj-$(CONFIG_MACH_GATEWAY7001) += gatewa
+@@ -32,6 +33,7 @@
obj-$(CONFIG_MACH_WG302V2) += wg302v2-setup.o
obj-$(CONFIG_MACH_FSG) += fsg-setup.o
obj-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/compex-setup.c
-===================================================================
--- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/compex-setup.c
++++ b/arch/arm/mach-ixp4xx/compex-setup.c
@@ -0,0 +1,120 @@
+/*
+ * arch/arm/mach-ixp4xx/compex-setup.c
@@ -162,11 +156,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/compex-setup.c
+ .init_machine = compex_init,
+MACHINE_END
+#endif
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixdp425-pci.c
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/ixdp425-pci.c
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/ixdp425-pci.c
-@@ -66,7 +66,7 @@ struct hw_pci ixdp425_pci __initdata = {
+--- a/arch/arm/mach-ixp4xx/ixdp425-pci.c
++++ b/arch/arm/mach-ixp4xx/ixdp425-pci.c
+@@ -66,7 +66,7 @@
int __init ixdp425_pci_init(void)
{
if (machine_is_ixdp425() || machine_is_ixcdp1100() ||
@@ -175,11 +167,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixdp425-pci.c
pci_common_init(&ixdp425_pci);
return 0;
}
-Index: linux-2.6.25.4/arch/arm/tools/mach-types
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/tools/mach-types
-+++ linux-2.6.25.4/arch/arm/tools/mach-types
-@@ -1276,7 +1276,7 @@ oiab MACH_OIAB OIAB 1269
+--- a/arch/arm/tools/mach-types
++++ b/arch/arm/tools/mach-types
+@@ -1276,7 +1276,7 @@
smdk6400 MACH_SMDK6400 SMDK6400 1270
nokia_n800 MACH_NOKIA_N800 NOKIA_N800 1271
greenphone MACH_GREENPHONE GREENPHONE 1272