aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq807x/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq807x/image/generic.mk')
-rw-r--r--target/linux/ipq807x/image/generic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index 1e74015e18..609c6690d1 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -71,6 +71,23 @@ define Device/edimax_cax1800
endef
TARGET_DEVICES += edimax_cax1800
+define Device/netgear_wax218
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ ARTIFACTS := web-ui-factory.fit
+ DEVICE_VENDOR := Netgear
+ DEVICE_MODEL := WAX218
+ DEVICE_DTS_CONFIG := config@hk07
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SOC := ipq8072
+ ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
+ ubinize-kernel | qsdk-ipq-factory-nand
+ DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
+ ipq-wifi-netgear_wax218
+endef
+TARGET_DEVICES += netgear_wax218
+
define Device/qnap_301w
$(call Device/FitImage)
DEVICE_VENDOR := QNAP