aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/modules.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
index 605504b0c3..a2b844d0f0 100644
--- a/target/linux/ipq806x/modules.mk
+++ b/target/linux/ipq806x/modules.mk
@@ -14,3 +14,32 @@ define KernelPackage/phy-qcom-ipq806x-usb/description
endef
$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
+
+
+define KernelPackage/sound-soc-ipq8064-storm
+ TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
+ DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
+ KCONFIG:=\
+ CONFIG_IPQ_LCC_806X \
+ CONFIG_SND_SOC_QCOM \
+ CONFIG_SND_SOC_STORM \
+ CONFIG_SND_SOC_APQ8016_SBC=n \
+ CONFIG_SND_SOC_SC7180=n
+ FILES:=\
+ $(LINUX_DIR)/drivers/clk/qcom/lcc-ipq806x.ko \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
+ $(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
+ AUTOLOAD:=$(call AutoProbe,lcc-ipq806x \
+ snd-soc-max98357a snd-soc-lpass-ipq806x snd-soc-storm)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-ipq8064-storm/description
+ Provides sound support for the Google Storm platform, with a Qualcomm IPQ8064
+ SoC.
+endef
+
+$(eval $(call KernelPackage,sound-soc-ipq8064-storm))