aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/modules.mk')
-rw-r--r--target/linux/ipq806x/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
new file mode 100644
index 0000000000..605504b0c3
--- /dev/null
+++ b/target/linux/ipq806x/modules.mk
@@ -0,0 +1,16 @@
+define KernelPackage/phy-qcom-ipq806x-usb
+ TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
+ DEPENDS:=@TARGET_ipq806x
+ KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
+ FILES:= \
+ $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/phy-qcom-ipq806x-usb/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))