aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/modules.mk')
-rw-r--r--target/linux/ipq806x/modules.mk32
1 files changed, 0 insertions, 32 deletions
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
deleted file mode 100644
index 57121bebb0..0000000000
--- a/target/linux/ipq806x/modules.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-define KernelPackage/usb-phy-qcom-dwc3
- TITLE:=DWC3 USB QCOM PHY driver
- DEPENDS:=@TARGET_ipq806x
- KCONFIG:= CONFIG_PHY_QCOM_DWC3
- FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
- AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-phy-qcom-dwc3/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
-
-
-define KernelPackage/usb-dwc3-qcom
- TITLE:=DWC3 USB QCOM controller driver
- DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3 +kmod-usb-phy-dwc3-qcom
- KCONFIG:= CONFIG_USB_DWC3_QCOM
- FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-qcom.ko
- AUTOLOAD:=$(call AutoLoad,53,dwc3-qcom,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-dwc3-qcom/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-dwc3-qcom))