aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 93e7ba3151..acb95347bf 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -284,6 +284,20 @@ define Device/netgear_r7800
endef
TARGET_DEVICES += netgear_r7800
+define Device/netgear_xr500
+ $(call Device/DniImage)
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := Nighthawk XR500
+ SOC := qcom-ipq8065
+ KERNEL_SIZE := 4096k
+ NETGEAR_BOARD_ID := XR500
+ NETGEAR_HW_ID := 29764958+0+256+512+4x4+4x4+cascade
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+endef
+TARGET_DEVICES += netgear_xr500
+
define Device/qcom_ipq8064-ap148
$(call Device/FitImage)
$(call Device/UbiFit)